Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted Apr 13, 2021 - 04:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2021 - 02:18 UTC
Identified
There are temporary delays with Malaysia withdrawals due to unexpected technical issues faced by our banking partner. We’re working closely with the bank to see this resolved soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Apr 12, 2021 - 09:20 UTC