PayU Maintenance in South Africa
Incident Report for Luno
Resolved
The scheduled maintenance has been completed.
Posted Oct 20, 2020 - 05:13 UTC
Investigating
One of our payments providers PayU will be performing some platform maintenance starting at 03:00 on 20 October 2020.

This may affect deposits through PayU on our app. Please use an alternative depositing method until the maintenance is complete.
Posted Oct 19, 2020 - 13:38 UTC