Slow cryptocurrency sends and receives
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 06:55 UTC
Monitoring
BTC, LTC BCH and USDC sends have returned to normal.
Posted Mar 04, 2021 - 20:07 UTC
Update
We are continuing to work on this as a priority. You still may experience slow send and receives.

We apologise for any inconvenience.
Posted Mar 04, 2021 - 13:27 UTC
Identified
BTC, XRP, LTC, BCH and USDC send and receives transactions may be slow for some customers, we're working on this as a priority.

Updates to follow
Posted Mar 04, 2021 - 10:59 UTC
This incident affected: Crypto sends and receives (BTC, BCH, XRP, LTC, USDC).