Delayed Bank Deposits in Australia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 07:11 UTC
Investigating
Our service provider will be undergoing an urgent system maintenance tonight from 9.30pm - 11pm AEST. Please avoid making deposits during this interrupted period.
Posted Apr 14, 2021 - 03:47 UTC
This incident affected: Bank deposits and withdrawals (Australia).