Delayed bank withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 17 days ago. May 09, 2019 - 04:51 UTC
Identified
Withdrawals in South Africa will not be processed on 8 May 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 9 May 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted 19 days ago. May 07, 2019 - 08:24 UTC