Account verification in Malaysia
Incident Report for Luno
Resolved
All Malaysian customers are being verified as normal, thanks for your patience!
Posted Dec 31, 2021 - 13:23 UTC
Monitoring
We're working through the backlog quite quickly and are seeing good results from our fix, monitoring closely for any additional errors.
Posted Dec 31, 2021 - 11:14 UTC
Identified
Unfortunately customers may see longer than usual account verification times in Malaysia due to a third party issue. We've tried implementing a fix, but this hasn't help - we're waiting on feedback from them.

Accounts already verified will not have an issue, however customers signing up in Malaysia from 27 December 2021 may experience a longer than normal wait to have their account verified.

We're sincerely sorry about the inconvenience caused - we hope to see this resolved soon.
Posted Dec 30, 2021 - 17:53 UTC