Delayed bank withdrawal in Zambia
Incident Report for Luno
Resolved
Withdrawals are now being processed according to schedule.

Thank you.
Posted May 26, 2020 - 06:24 UTC
Identified
Withdrawals in Zambia will not be processed on 25th May due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 26th May.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted May 22, 2020 - 10:21 UTC