Account verification delays in Nigeria
Incident Report for Luno
Resolved
Account verification times have returned to normal.
Posted 3 months ago. May 03, 2019 - 06:26 UTC
Investigating
Customers in Nigeria waiting to be verified to Level 1 may experience slower than normal verification times. This is due to our third party verification service seeing degraded performance.

We're currently communicating with them to see this resolved as quickly as possible.

Our team will have all Nigerian customers verified as soon as possible.
Posted 3 months ago. May 01, 2019 - 18:26 UTC