Delayed bank withdrawals in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Dec 13, 2021 - 02:58 UTC
Identified
There may be temporary delays with Indonesia withdrawals requested on 10th and 11th December as payment provider portal is having maintenance.

Maintenance will be conducted on:
Day, Date: Friday-Saturday, 10-11 December 2021
Time: 11:30 PM - 01:30 AM
Duration: 60 minutes

and

Day, Date: Saturday-Sunday, 11-12 December 2021
Time: 11:30 PM - 01:30 AM
Duration: 60 minutes

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Dec 10, 2021 - 09:32 UTC