Slow Account Verification in Indonesia
Incident Report for Luno
Resolved
All account verifications in Indonesia are processing without any further delays.

Thank you for your patience.
Posted May 03, 2024 - 07:21 UTC
Monitoring
We're still monitoring account verification times, some customers may still experience slower than normal verification times.
Apologies again for the delays and thanks for your patience.
Posted Apr 25, 2024 - 14:09 UTC
Identified
Due to an issue with our verification partner, account verification for new customers in Indonesia may be slower than usual.

Our team are monitoring closely and will update this status page with more information as soon as it's available.

Thanks for your patience.
Posted Apr 20, 2024 - 14:04 UTC