Luno Planned Maintenance In Australia
Incident Report for Luno
Resolved
This maintenance has been completed and this incident has been resolved. Thank you for your understanding.
Posted May 29, 2022 - 00:35 UTC
Investigating
Please be advised that our service provider will be a doing planned maintenance on the deposits and withdrawals system this coming Sunday.

You may not be able to make deposits during this maintenance downtime. Appreciate if you could plan and make deposits before/after the following times:

Sunday, 29th May 2022 12.00 a.m. to 10.00 a.m.

Deposits and withdrawals will be affected during this period and will be processed after the maintenance is completed.

We’ll post an update once the maintenance has been completed.

Thanks for your understanding.
Posted May 27, 2022 - 07:44 UTC