Verification email sent in error
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 10 days ago. Oct 07, 2019 - 09:50 SAST
Monitoring
We’d like to extend our sincere apologies again to our customers who received this mail. Our team is in the process of wrapping up an extensive investigation and postmortem to ensure that something like this never takes place again.

A follow up mail has been sent to affected customers, no further action is required.

If there are further questions please feel free to follow up with our team via https://www.luno.com/help/tickets/new
Posted 15 days ago. Oct 02, 2019 - 12:17 SAST
Identified
Our team have identified the issue, a mailer campaign was triggered incorrectly. We will send a follow up mail with further details, apologies for the inconvenience caused.
Posted 17 days ago. Sep 30, 2019 - 12:19 SAST
Investigating
Our team are urgently investigating an issue where some customers have received an incorrect mail to verify your account, please ignore this for now.

Updates to follow shortly.
Posted 17 days ago. Sep 30, 2019 - 12:13 SAST