Delayed bank withdrawal in Uganda
Incident Report for Luno
Resolved
Withdrawals are being processed as scheduled.
Posted Aug 03, 2020 - 06:16 UTC
Identified
Withdrawals in Uganda will not be processed on 31 July due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 3rd August.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jul 31, 2020 - 10:22 UTC