Degraded performance on Luno
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 19:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2020 - 17:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 17, 2020 - 17:20 UTC
Investigating
We are currently investigating degraded performance with our app. We are looking into this as a matter of urgency.

Updates to follow.
Posted Nov 17, 2020 - 17:14 UTC