Slow Bank Deposits in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 04:20 UTC
Monitoring
Please note that there is an update to our service provider maintenance schedule. The updated time will be on Saturday, 12th June 2021 at 11:00AM - 4:00AM WIB time. Please avoid making deposits during this time.
Posted Jun 11, 2021 - 09:53 UTC
Identified
Our service provider will be undergoing maintenance work on Saturday, 12th June 2021 at 12:00AM - 3:00AM WIB time. Please avoid making deposits during this downtime.
Posted Jun 11, 2021 - 06:22 UTC