Slow bitcoin sends
Incident Report for Luno
Resolved
Bitcoin send transactions have returned to normal.
Posted Apr 25, 2024 - 19:38 UTC
Monitoring
The backlog has cleared completely, we're continuing to monitor transactions for any anomalies.
Posted Apr 25, 2024 - 18:53 UTC
Identified
We've identified a small backlog of transactions that are being processed slower than normal. This may affect some customers sending bitcoin from their wallets, our team is investigating.
Posted Apr 25, 2024 - 18:13 UTC