Instant Buy and Sell for BCH temporarily unavailable
Incident Report for Luno
Resolved
BCH Instant Buy and Sell orders are operating as normal.
Posted Oct 25, 2019 - 10:56 SAST
Monitoring
BCH Instant Buy and Sell orders should be processing as normal, we're monitoring this closely.
Posted Oct 25, 2019 - 10:10 SAST
Identified
Our team have identified an issue where BCH buys and sells placed via Instant Buy and Sell are taking longer than normal to be credited to other wallets. All orders will still be honoured however there may be a delay in completing the order.

Updates to follow.
Posted Oct 25, 2019 - 08:29 SAST