Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Sep 06, 2017 - 09:51 UTC
Identified
Due to a technical issue, some bank withdrawals have been delayed today. Apologies for any inconvenience.

Updates to follow.
Posted Sep 05, 2017 - 10:16 UTC