Intermittent issues with FPX deposit completion screen in Malaysia
Incident Report for Luno
Resolved
This issue has been resolved and the deposit confirmation screens are working as expected.
Posted Apr 17, 2024 - 09:26 UTC
Identified
We've identified an issue with our deposit confirmation screen after completing a deposit via FPX.

Despite successful deposits, some users may encounter an error message after completion.

We are working to resolve this as soon as possible and will provide further updates as soon as they become available.
Posted Apr 09, 2024 - 09:25 UTC