Slow ticket response times
Incident Report for Luno
Resolved
Our team have reduced the email backlog to normal levels, response times have returned to normal.
Thanks for your patience.
Posted Dec 05, 2019 - 15:01 UTC
Identified
If you get in touch with us today we might take a little longer to respond than usual. We’re experiencing a high number of incoming queries and are working through the backlog as quickly as we can.

Please bear with us while we work on getting back to you.
Posted Dec 02, 2019 - 08:56 UTC