Crypto send and receive transactions scheduled maintenance
Incident Report for Luno
Resolved
The scheduled maintenance has been completed.
Posted Apr 11, 2021 - 07:12 UTC
Identified
We'll be doing routine maintenance at 23:00 UTC to 02:00 UTC on 10 April 2021, this will last approximately 3 hours.

During this time send and receive transactions for BTC, XRP, LTC, BCH and USDC may be slow or unavailable.

Thanks for your understanding.
Posted Apr 09, 2021 - 08:11 UTC