Delayed USDT Withdrawals
Incident Report for
Luno
Resolved
The issue has been resolved by our provider.
Thank you for your patience
Posted
Apr
15
,
2026
-
06:19
UTC
Identified
We are experiencing slow responses on our usdt withdrawals. We are currently investigating the issue with our provider and will resolve as soon as possible.
We apologise for the inconvenience caused.
Posted
Apr
14
,
2026
-
16:50
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed USDT Withdrawals
via . You'll receive .