PayU Instant EFT deposits temporarily unavailable in South Africa
Incident Report for Luno
Resolved
This issue has been resolved.

Thank you.
Posted Nov 16, 2020 - 11:26 UTC
Identified
Instant EFT with PayU deposits are currently unavailable. We are working to get this issue resolved. In the meantime, please make use of an alternative deposit method in your Luno wallet.
Posted Nov 13, 2020 - 08:33 UTC