Slow USDC send transactions
Incident Report for Luno
Resolved
USDC sends are being processed as normal, thanks for your patience.
Posted May 14, 2021 - 10:40 UTC
Update
USDC sends have been re-enabled, some sends may still be slow. We're monitoring closely.
Posted May 13, 2021 - 13:00 UTC
Update
We've temporarily disabled USDC sends until we can properly resolve this.
Posted May 13, 2021 - 08:46 UTC
Identified
Our team has identified an issue affecting USDC send transactions, these have become slow since 12 May 2021 due to a fee spike. Unfortunately fees need to reduce to a point where we can process transactions again.

This only affects USDC sends from your Luno wallet to external parties, receive transactions are still being processed as normal.

Updates will be posted as soon as additional information becomes available.
Posted May 13, 2021 - 08:01 UTC
This incident affected: Crypto sends and receives (USDC).