Delayed bank deposits
Incident Report for Luno
Resolved
Deposits are being processed as normal.
Posted 16 days ago. Oct 01, 2019 - 10:56 SAST
Identified
Due to a system error, some countries may experience slower than normal bank deposits. This currently affects South Africa, Nigeria and Uganda.

Our team have already identified the issue and are working on a fix.
Posted 16 days ago. Oct 01, 2019 - 09:15 SAST