Delayed bank deposits in Australia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 01:45 UTC
Investigating
Instant Bank Transfers and PayID payments may be affected due to a network outage currently being experienced by our banking partner in Australia. Please expect delays in deposits as well as the possibility that your deposit may not be successful.

We're working closely with the our banking partner to see this resolved as quickly as possible. Thanks for your patience.
Posted Feb 18, 2021 - 03:05 UTC