Delayed BCH Sends and Receives
Incident Report for Luno
Resolved
All BCH transactions have returned to normal.

We thank you for your patience.
Posted Jun 16, 2021 - 13:35 UTC
Monitoring
BCH transactions are being processed successfully. We will monitor closely for any further issues.

Thanks for your patience.
Posted Jun 16, 2021 - 12:01 UTC
Identified
We have identified an issue causing BCH sends and receives to be delayed, our team is working on this as a priority.
Posted Jun 16, 2021 - 11:12 UTC
This incident affected: Crypto sends and receives (BCH).