Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted Jun 07, 2022 - 01:54 UTC
Identified
Withdrawals in Malaysia will not be processed on 6th June 2022 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 7th June 2022.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jun 06, 2022 - 03:51 UTC