Promotion referrals in Europe
Incident Report for Luno
Resolved
Referral redemptions have returned to normal.
Posted Dec 27, 2019 - 08:01 UTC
Monitoring
All promotion codes for the limited spend 15 EUR and receive 15 EUR worth of BTC have been redeemed

Thank you to everyone who participated.
Posted Dec 23, 2019 - 10:06 UTC
Investigating
We're experiencing a high volume in referrals, there may be delays in processing the reward.

An update will be provided as soon as more information is available. We do apologize for the inconvenience.
Posted Dec 22, 2019 - 01:40 UTC