Slow Bitcoin transactions
Incident Report for Luno
Resolved
Bitcoin transaction times have returned to normal, we'll continue to monitor for any further anomalies.
Posted Oct 21, 2020 - 11:30 UTC
Investigating
Slower block times, as well as a spike in fees, has resulted in a backlog of transactions on the Bitcoin blockchain.

This is out of Luno's control, thankfully this usually clears quite quickly. We'll keep a close eye on transactions.
Posted Oct 20, 2020 - 19:21 UTC