Delayed bank withdrawals
Incident Report for Luno
Resolved
All withdrawals are being processed as normal.
Posted 24 days ago. May 02, 2019 - 07:13 UTC
Identified
Due to a public holiday on Wednesday 1 May 2019, some countries will experience delayed bank withdrawals as banks do not process withdrawals over weekends and public holidays.

Withdrawals requested on 1 May 2019 will be processed and released on 2 May 2019 for the following countries:

South Africa
Nigeria
Indonesia
Malaysia
Posted 26 days ago. Apr 30, 2019 - 07:07 UTC