Slow bank withdrawals in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 22 days ago. May 03, 2019 - 14:21 UTC
Update
Some customers may still experience delays with their bank withdrawals, our team are working on a resolution.
Posted 27 days ago. Apr 29, 2019 - 07:27 UTC
Identified
There will be a slight delay with Indonesian bank withdrawals requested on 26 April 2019. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted 30 days ago. Apr 26, 2019 - 08:39 UTC