Slow FPX Deposits in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Apr 21, 2021 - 01:56 UTC
Monitoring
Service provide maintenance has completed. FPX service should be back to normal.
Posted Apr 21, 2021 - 01:45 UTC
Investigating
Our service provider will be undergoing an urgent maintenance from 11PM on 20 April 2021 until 1AM on 21 April 2021. Please avoid making FPX deposits during this interrupted period.

Thank you.
Posted Apr 20, 2021 - 11:50 UTC