Slow Bank Deposits in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Feb 11, 2021 - 09:49 UTC
Update
Issues with deposit delays have been resolved. Thank you for your understanding.
Posted Feb 11, 2021 - 09:49 UTC
Investigating
We're aware of a technical issue with FNB deposits. We are in contact with the bank to investigate the problem and we hope to have it resolved soon. In the meantime, please make use of an alternative bank account to make a deposit in to your Luno wallet.
Posted Feb 04, 2021 - 14:11 UTC