Public Holiday Reminder - Withdrawal Requests will take longer than usual in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 08:54 UTC
Identified
Please note that 29.03.2024 and 1.04.2024 are Public Holidays in South Africa, which means the Banks will not process withdrawals on these days.

This only applies to ZAR withdrawals, Crypto withdrawals will be processed as normal according to our service level agreements.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Mar 28, 2024 - 13:22 UTC