Delay in account verification in Nigeria
Incident Report for Luno
Resolved
We have managed to restore processing customer verification with minimal delays as we continue to work through the pending requests. We will strive to work through these requests as efficiently as possible.
Posted Nov 05, 2021 - 13:24 UTC
Identified
We have identified an issue causing a delay with the processing of customer verification through documentless verification in Nigeria. Our engineers are working to ensure that this issue is fixed promptly.
Posted Nov 04, 2021 - 11:38 UTC
This incident affected: Help & account verification (Account verification).