Exchange Errors
Incident Report for Luno
Resolved
No further errors are being reported, we'll continue to monitor for any further anomalies.
Posted Nov 04, 2021 - 20:19 UTC
Investigating
We’re investigating an issue with errors on our exchange.
Our team are working on a fix as a priority.
Posted Nov 04, 2021 - 19:52 UTC