Bank deposit method unavailable in Singapore
Incident Report for Luno
Resolved
The issue has been resolved and bank transfers should be visible as a deposit option for all affected customers. Thank you for your patience.
Posted May 02, 2022 - 14:42 UTC
Identified
The issue has been identified. Deposits are still possible through bank transfers for customers that know their unique bank account number which is used for Luno deposits.
Posted May 02, 2022 - 11:54 UTC
Investigating
We are investigating reports that some of our customers in Singapore are not getting the option to deposit funds through the bank deposit method. We'll provide an update as soon as we have identified the cause.
Posted May 02, 2022 - 11:29 UTC