Interrupted Bank Deposits in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted May 06, 2022 - 09:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 06, 2022 - 08:28 UTC
Investigating
You may be experiencing an issue when depositing with your VA number. Rest assured that our team is aware of this and is currently investigating it with our bank partner. We will inform you once the issue is fixed. Thank you.
Posted May 06, 2022 - 06:35 UTC