Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Dec 28, 2020 - 02:56 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 22, 2020 - 09:59 UTC
Identified
Withdrawals in Indonesia will not be processed on 24th and 25th December 2020 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays. The cutoff for last withdrawal process will be 23rd December 2020 13:00 WIB.

Requested withdrawals will be processed on 28th December 2020.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Dec 22, 2020 - 09:59 UTC