Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
This issue has been resolved. Withdrawals are being processed accordingly.
Posted Jul 01, 2020 - 17:43 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 01, 2020 - 07:10 UTC
Identified
There may be temporary delays with some Nigeria withdrawals requested on 30th June and 1 July. We’re working with our payment provider to see this resolved soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Jun 30, 2020 - 16:11 UTC