Delayed deposits and withdrawals in Nigeria
Incident Report for
Luno
Resolved
All deposits and withdrawals are currently being processed without any issues.
We apologise for any inconvenience this may have caused.
Posted
Jan
14
,
2025
-
13:39
UTC
Identified
We are currently experiencing intermittent delays with deposits & withdrawals via bank transfers due to issues with one of our third-party providers.
We are working closely with them to get this resolved.
We apologise for any inconvenience caused and appreciate your patience.
Posted
Jan
13
,
2025
-
08:54
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed deposits and withdrawals in Nigeria
via . You'll receive .