Degraded performance on Luno
Incident Report for Luno
Resolved
Services have returned to normal across the board, thanks for your patience during this time.
Posted Dec 26, 2020 - 22:30 UTC
Investigating
We are currently investigating degraded performance. We are looking into this as a matter of urgency.

Some actions on Luno may be slow due to large price movements in the market.

Buying and selling are still operational but may take longer to execute.
Posted Dec 26, 2020 - 16:31 UTC