Slow Crypto Sends
Incident Report for Luno
Resolved
All send and receives have returned to normal.
Posted Sep 02, 2021 - 05:33 UTC
Monitoring
We are monitoring an issue that may have affected crypto sends and receives for XRP.

Some sends remain in a processing state, we're working hard to process this backlog as soon as possible.
Posted Sep 02, 2021 - 04:19 UTC
This incident affected: Crypto sends and receives (XRP).