Delayed bank withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed accordingly. Thank you for your patience.
Posted Jan 05, 2021 - 12:39 UTC
Identified
There may be temporary delays with South Africa withdrawals requested on January 5th. We’re working to see this resolved soon.
Posted Jan 05, 2021 - 10:55 UTC