Slow FPX Deposits in Malaysia
Incident Report for Luno
Resolved
FPX deposits are now being processed as scheduled. Thank you
Posted Nov 05, 2021 - 09:19 UTC
Investigating
We're aware of a delay with FPX deposits and our team is currently investigating it. We hope to have this resolved soon.
Posted Nov 05, 2021 - 02:08 UTC