Slow Deposits in Nigeria
Incident Report for Luno
Resolved
This issue has been resolved.

Thank you.
Posted Oct 20, 2020 - 08:27 UTC
Investigating
We're aware of an issue with Flutterwave Pay with Bank deposits and our team is currently investigating it. We are working with the provider and hope to have this resolved soon. In the meantime, please make use of an alternative deposit method in your Luno wallet.
Posted Oct 19, 2020 - 07:19 UTC