Delayed bank withdrawal in Australia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 03:57 UTC
Identified
Withdrawals in Australia will not be processed on January 1, 2021 due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on January 4, 2021 .

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Dec 30, 2020 - 07:39 UTC