Slow Deposits via Bank Transfer in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Feb 17, 2021 - 14:59 UTC
Update
We are continuing to investigate this issue.
Posted Feb 05, 2021 - 05:38 UTC
Investigating
We're aware of a delay with deposits via Bank Transfer and our team is currently investigating it. We hope to have this resolved soon. In the meantime, please make use of FPX, an alternative deposit method in your Luno wallet.
Posted Feb 05, 2021 - 05:38 UTC