Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Feb 02, 2021 - 01:50 UTC
Identified
Withdrawals in Malaysia will not be processed on 1st February 2021 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 2nd February 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jan 29, 2021 - 03:43 UTC